易语言资源网 易语言资源网

高质量编程资源聚合平台

热词:网络通讯浏览器生产管理excel多开器源码

易语言资源网

网站首页 > 易语言教程 >图文教程 > 正文 UP:1个月前

易语言教程:生成九九乘法表源码

作者: 小众资源  发布时间:2024-04-30 资源分类:图文教程 阅读:0

易语言生成九九乘法表可以通过编写一个简单的循环结构来实现。

下面是一段示例代码,演示如何在易语言环境中输出九九乘法表到一个编辑框组件中:

.版本 2

.局部变量 容器, 整数型, , "0", 文本数组
.局部变量 计次1, 整数型
.局部变量 计次2, 整数型
.局部变量 分割符, 文本型, , , 空格

' 清空编辑框内容
编辑框1.内容 = “”

.计次循环首 (9, 计次1)
    加入成员 (容器, 计次1)
    .计次循环首 (取数组成员数 (容器), 计次2)
        .如果真 (取数组成员数 (容器) > 1 且 容器 [计次2] = 1)
            编辑框1.加入文本 (#换行符)
        .如果真结束
        .如果 (取文本长度 (到文本 (容器 [计次2] × 计次1)) = 1)
            分割符 = “  ”
        .否则
            分割符 = “ ”
        .如果结束

        编辑框1.加入文本 (到文本 (容器 [计次2]) + “ × ” + 到文本 (计次1) + “ = ” + 到文本 (容器 [计次2] × 计次1) + 分割符)
        处理事件 ()
    .计次循环尾 ()
.计次循环尾 ()

以上代码首先定义了一个易语言程序集,并在_启动子程序中通过两个嵌套的 计次循环首 来生成九九乘法表。

每次循环迭代时,它会计算当前的乘积(j*i) 并将其转换为文本,然后追加到编辑框的内容中,每完成一行乘法表达式后添加一个换行符(#换行符)以便于阅读。此外,还提供了一个_按钮1_被单击 子程序示例,意味着你可以通过点击一个按钮来触发九九乘法表的生成,尽管在这个例子中直接在启动时生成了乘法表。

请根据你的具体需求调整编辑框组件的名称(如编辑框1)以及其他可能存在的组件或事件处理程序。

易语言生成九九乘法表

最新资源
热门资源推荐
资源标签展示